Jump to content
Sign in to follow this  
Guest Alex

Phoenix Safe

Recommended Posts

Guest Alex

Hy i have a problem with a safe as well is from Phoenix model 0996E , one of my staff try out to open the same yesterday and put the password wrong 6 times and now the same show on screen 'delay' and keeps beeping . can somebody tell me how to sort this one out ? please .

Share this post


Link to post
Share on other sites

If an incorrect passcode is entered 5 times the screen will display delay for 5 minutes. After the five minutes you can enter the correct code and the safe should unlock normally.

If you have lost or forgotten the code you may need to have a locksmith open it for you.

Edit: After speaking with the manufacturer, they have informed me that they may be able to help you get the safe open if you are still having difficulties. If you could send your name and telephone number to shawn@safelincs.co.uk I can ask them to give you a call.

Share this post


Link to post
Share on other sites

Your content will need to be approved by a moderator

Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoticons maximum are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×