Jump to content
Jim Allen

Fire Alarm Problem

Recommended Posts

Hi, new member seeking advice, we recently took over the lease at a industrial property that has an existing fire alarm system. I have started doing weekly call point tests which we carried out successfully, however when we tried triggering call point 6 no sounders triggered but on the alarm panel it showed a general fault. When I reset the call point the fault disappeared.  Can any body help?

Share this post


Link to post
Share on other sites

I think it is pretty obvious that there is a fault, and the sounders should operate and the zone flash red, you need to get in touch with your fire alarm company, getting them to sort out the problem.

Share this post


Link to post
Share on other sites

It needs to be corrected by a competent person. My guess is its wired wrong, or it is the wrong type of call point for your fire alarm panel.

Not all call points are the same (other than the colour) fire panels look for various things (depending on panel) to indicate fire or fault, some use resistors other use diodes some have a "chip" if when activated the panel does not see what it is looking for then it shows a fault condition which will clear when the BGU is reset (as yours did) this indicates the cable is working but the call point itself is the problem.

Share this post


Link to post
Share on other sites

Your content will need to be approved by a moderator

Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×